thetankatwaterheaterrescue.com Home 
Home Search search Menu menu Not logged in - Login | Register
thetankatwaterheaterrescue.com > Forums > The Tank > RobertShaw ignition issues

 Moderated by: Admin
New Topic Reply Printer Friendly
RobertShaw ignition issues  Rating:  Rating
AuthorPost
 Posted: Tue Sep 15th, 2009 06:04 pm
  PM Quote Reply
1st Post
jjslater
Member


Joined: Tue Sep 15th, 2009
Location:  
Posts: 2
Status: 
Offline
My water heater is 4 years old.
Ruud PVRP40N
with a
RobertShaw 2000wiper-LC
AP12556-2
665291005 002230844

The PWB has the part number FC60187 Rev S 320358

Okay, so. Water heater just stopped working today, no prior issues except the occasional lock-out due to burner not lighting after 3 tries. Unplug and plug back in and it worked just fine for another 3 months or so until the next time.
This morning, water heater didn't kick on and it was in lock out mode. Un plug, plug in, doesn't light. I start checking everything today, and I have gas to the valve and lots of spark. I take the Ignition controller off and take a look over the PWB. I see what appears to be a carbon short between 2 pins of the IC right above where C11 is located on the back side of the board. I clean the area and reassemble. The burner lit after a few seconds, but quickly went out and resumed the sparking.
My suspicions are that the valve is not being switched to let gas into the burner, and am fairly certain it's the controller board.
Does anybody know the history of these? Also, I can't find someone online that sells this thing. The part number doesn't even register. It would be nice if I could just buy the control card (FC60187).

Back To Top PM Quote Reply  

 Posted: Thu Sep 17th, 2009 02:00 am
  PM Quote Reply
2nd Post
Ej
Member


Joined: Thu Aug 24th, 2006
Location: USA
Posts: 783
Status: 
Offline
Make sure the flame rod is clean and the wire connections are tight.  Lightly sand the flame rod with some fine sand paper.

Back To Top PM Quote Reply

 Posted: Thu Sep 17th, 2009 02:07 am
  PM Quote Reply
3rd Post
jjslater
Member


Joined: Tue Sep 15th, 2009
Location:  
Posts: 2
Status: 
Offline
Thanks for the reply.
I'm pretty sure I was right about the controller card being bad. Regardless, I ended up calling Ruud, and found out my water heater had a 10 year warranty on parts (it's only 4 years old now). After 5 mins with the tech rep, he said he'd overnight me a full valve assembly with controller. I got it today, and installed it. Now my water heater works.
I really have to give Ruud a hand. They have amazing customer service. I'm only buying Ruud/Rheem here on out.

Justin

Back To Top PM Quote Reply  

Current time is 07:35 pm  
thetankatwaterheaterrescue.com > Forums > The Tank > RobertShaw ignition issues Top




UltraBB 1.17 Copyright © 2007-2008 Data 1 Systems